NoW 365 oFS - Invite users to this share is stuck with a spinning circle with "adding user" status.
Updated on: Nov 19th, 2025
Applies to: oFS FileCloud , FileCloud Sync for Windows
Symptoms
When sharing using account sharing mode (This means the specified external account must be created, registered and approved) the system seems to be stuck with Adding Users.
Cause
The process may be actually stuck, or the email address (Invited users) may be disabled, or a security policy may not be set to allow automatic to approve external email addresses.
Resolution
Solution 1:
Try close the file share dialog and try again.
Solution 2
Ask your oFS FileCloud site admin to check to and see if the email address that you are trying to share files with is disabled in the back-end, or check to see if security policies are not in place for automatic approval of external email addresses.