NoW 365 oFS - Getting "Invalid path for share" error message when sharing files in Windows Explorer
Updated on: Nov 19th, 2025
Symptoms
Using FileCloud Sync App in Windows, when sharing a file or folder inside My Files using Windows File Explorer, an error message will occur “Invalid Path for Share”
Cause
This problem occurs when you are using FileCloud Sync App and signed in with your email instead of the username and trying to share a file or folder inside the My Files folder. This does not seem to impact sharing files and folders within the Team Folders. FileCloud allows users to sign-in using their FileCloud username or the associated email address. This is a bug, and the technology vendor is fully aware of the problem. Software developers are hoping to resolve this issue in the next FileCloud Sync for Windows release.
Resolution
Solution 1:
Reset FileCloud (see guide NoW 365 oFS - How to reset oneFile Sync (Windows) )
Sign into FileCloud again using your username instead of your email address.