NoW 365 oFS - Files saved or updated by users are not syncing or appearing for other users.
Updated on: Nov 19th, 2025
Symptoms
When a user updates, creates, deletes, or modifies files and folders on their local system, the changes are not being synchronized to the server or reflected for other users with access to the files under Team Share or My Files
Cause
This issue can happen for several reasons, such as a weak or unstable internet connection, the sync application not running or not running properly, incorrect application or account settings, insufficient storage space, permission issues, outdated software, file naming conflicts, File Sync account sharing or temporary server problems
Resolution
This is for testing only. Do not apply in production environment
Solution 1:
Check to make sure FileCloud Sync is running properly
Solution 2:
Make sure the user has write permissions for the file sync operation.
Solution 3:
Make sure there is sufficient File Share cloud storage to accept the new changes
Solution 4:
Make sure your File Sync application is up-to-date.